Pulse Status
Incident History
Subscribe via RSS
Client/Patient Search Outage
Resolved
severity: major
Resolved
— Client/Patient Search Outage — resolved.
May 26, 20:00 UTC
Identified
— Customers were unable to search for clients or patients, limiting critical workflows.
May 26, 19:15 UTC
Investigating
— Investigating: Client/Patient Search Outage.
May 26, 19:13 UTC