Pulse Status
Incident History
Subscribe via RSS
Exam Form and Task Dashboard Service Interruption
Resolved
severity: minor
·
Up to 0.19% of customers impacted
Resolved
— Recovered, tasks and exam forms fully functional
Aug 24, 08:30 AM EDT
Investigating
— Slow loading tasks and exam form components, intermittent errors when saving.
Aug 24, 08:10 AM EDT