Exam Form and Task Dashboard Service Interruption
Resolved — Recovered, tasks and exam forms fully functional
Monitoring — Service recovered, monitoring to resolution.
Investigating — Engaging in review in response to service alerts
Identified — Slow loading tasks and exam form components, intermittent errors when saving.