Pulse Status

Exam Form and Task Dashboard Service Interruption

Resolved severity: minor Up to 8.25% of customers impacted

Resolved — Fully recovered, tasks and exam forms fully functional.
Monitoring — Service recovering, monitoring to resolution.
Investigating — Engaging in review in response to service alerts
Identified — Exam Form and Task Dashboard Service Interruption resulting in slow loading and intermittent errors with exam forms and tasks