Pulse Status

Exam Form and Task Dashboard Service Interruption

Resolved severity: minor Up to 10.27% of customers impacted

Resolved — We are continuing to see exam forms and task updates operate as expected, we will continue to monitor
Monitoring — Exam form and task update processes are recovered at this time, continued aggressive monitoring
Investigating — Exam form and task saves presenting intermittent errors and slowness to update data within the user interface.
Monitoring — Recovery achieved, improvements in tasks and exam form performance.
Investigating — Slow loading tasks and exam form components, intermittent errors when saving.