Delays Opening Calendar/Employee Drop Down
Resolved — We're continuing to see improved performance.
Monitoring — New calendar and appointments/activities have recovered, we are continuing to monitor to ensure there is no reoccurrence.
Investigating — We have identified an issue impacting new calendar and appointment/activities.