Pulse Status

Client and Patient Data Not Loading

Resolved severity: major Up to 94.36% of customers impacted

Resolved — The issues impacting core services have been resolved.
Monitoring — We are monitoring the resolution to the clients and patients not loading.
Investigating — We are working to resolve the client and patient information not loading. Some additional medical record highlights may be loading slowly for some customers.