Microsoft Azure Outage in West Region Impacting Multiple eVet Servers
Resolved — We are continuing to see recovered performance across the West region.
Monitoring — What's happening: Microsoft Azure is reporting recovery from the networking issues in its West region. Details are available on Azure's status page: https://azure.status.microsoft/en-us/status
Current status: Latency in the West region has returned to normal levels, and loading and saving of exam forms and tasks should be performing as expected.
What's next: We will continue to closely monitor performance to confirm the recovery holds.
Monitoring — What's happening: The Microsoft Azure networking issues in the West region are ongoing. Azure continues to post updates on its status page: https://azure.status.microsoft/en-us/status
Current impact: Some customers in the West region may continue to experience elevated latency when loading and saving exam forms and tasks. Connectivity remains restored for directly impacted customers in W3 and W5.
What we're doing: Our teams are actively deploying mitigations to reduce the impact of the underlying Azure issues and are monitoring the situation continuously.
Monitoring — What's happening: Microsoft Azure has confirmed networking issues in its West region affecting all Azure customers. Azure is posting updates on its status page: https://azure.status.microsoft/en-us/status
Progress: As of 16:28 UTC (12:28pm EDT / 9:28am PDT), our recovery efforts have restored connectivity for directly impacted customers in W3 and W5.
Ongoing impact: Some customers in the West region may still experience elevated latency loading and saving exam forms and tasks. We are actively working on mitigations while the underlying Azure issues persist.
Identified — We have restored service to half of the impacted customers. W5 customers are able to access the site. We are continuing work to restore service on W3 and expect restoration in the next 20 minutes.
Investigating — We have identified a drop in traffic to the W3 and W5 servers and are actively working to restore service outside the impacted region.