Lab Ordering/Results Errors
Resolved — Lab order and result processing functionality fully restored. Lab results are flowing back in now and new orders can be placed successfully.
Identified — Issue identified and isolated to lab ordering and results service. We are working to restore functionality. All other services remain unaffected.
Investigating — Investigating delays and errors in lab ordering and results.