Pulse Status

Appointment Display Issue

Resolved severity: minor

Resolved — Appointment Display Issue — resolved.
Identified — A display issue caused appointments to appear cut off for a subset of customers. Isolated to a small number of servers.
Investigating — Investigating: Appointment Display Issue.