User Switching and Exam Form Delays
Resolved — User Switching and Exam Form Delays — resolved.
Identified — Some customers were unable to switch between users in the UI, and exam forms were slow to load.
Investigating — Investigating: User Switching and Exam Form Delays.