Medical Records Slow to Load
Resolved — Medical Records Slow to Load — resolved.
Identified — Medical Records were slow to load or intermittently unavailable due to degraded database response times. Performance was restored.
Investigating — Investigating: Medical Records Slow to Load.