Pulse Status

Slow Load Times/Errors in East Region

Resolved severity: minor

Resolved — Slow load times and errors fully resolved in the East Region. Cloudflare have addressed the underlying issue on their end.
Identified — Root cause identified: a provider incident due to a cut fiberoptic cable. We are working with Cloudflare on resolution to ensure traffic is routed around the issue.
Investigating — Investigating a spike in errors in the East Region.