Pulse Status

Medical Records Errors

Resolved severity: major

Resolved — Medical Records Errors — resolved.
Identified — Some customers could not load Medical Records and saw an error when viewing records with lab or exam form results.
Investigating — Investigating: Medical Records Errors.